QQ登录

只需一步,快速开始

蓝筹投资家园---股票论坛证券网站,百强社区

搜索
楼主: 夏雪儿
打印 上一主题 下一主题
收起左侧

经典飞狐源码公式大全(不断更新)

  [复制链接]
61#
 楼主| 发表于 2004-10-5 12:17:42 | 只看该作者
天龙八部1}
MID:=FORCAST(CLOSE,11);
上轨:=MID*1.025;
下轨:=MID*0.975;
极限:=(C-下轨)/(上轨-下轨)*100;
波动因子:MA(极限-REF(极限,1),3)+50,COLOR00FF00;
【波动极限】:50,COLORWHITE;

{天龙八部2}
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
D:=SMA(CCC,3,1);
【逃顶至尊1】:if(CROSS(D,RSI5),50,0),STICK,COLORMAGENTA;
【逃顶至尊2】:if(CROSS(80,RSI5),-50,0),STICK,COLORGREEN;
STICKLINE(CROSS(D,RSI5),50,0,6,0),COLORMAGENTA;
STICKLINE(CROSS(80,RSI5),-50,0,6,0),COLORGREEN;
回复 支持 反对

使用道具 举报

62#
 楼主| 发表于 2004-10-5 12:18:04 | 只看该作者
请关注蓝筹投资官方微信
天龙八部3}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A:=(J-D);
波段至尊:MA(A-REF(A,1),3)+80,COLOR0066FF;
【生死线】:80,COLORCYAN


K-太极}
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短K:SMA(RSV,3,1),COLORWHITE;
短D:SMA(短K,3,1),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
STICKLINE(短K>短D,短K,短D,6,0),,COLORYELLOW;
STICKLINE(短K<=短D,短K,短D,6,0),COLORGREEN;


回复 支持 反对

使用道具 举报

63#
 楼主| 发表于 2004-10-5 12:18:27 | 只看该作者
礼金波段 n,1,100,5}
VAR1: MA(EMA(CLOSE,55)*0.88,5);
VAR2: REF(CLOSE,N);
IF(CROSS(VAR1,VAR2)=1,VAR1*1.5,VAR1);
DRAWICON(CROSS(VAR1,VAR2)=1,VAR1*1.5,1);


技术指标公式:英雄无敌 缺省周期:日线}
{参数描述: N(1,100,3)N1(5,5,5)N2(5,5,5)N3(12,12,12)}
Var1:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var2:=Var1+Var1*34/100;
Var3:=LOW;
Var4:=REF(LOW,1);
Var5:=SMA(ABS(Var3-Var4),3,1)/SMA(MAX(Var3-Var4,0),N,1)*100;
Var6:=MA(IF(CLOSE*1.68<="CYC@CYCMAX",Var5*10,Var5/10),N);
Var7:=LLV(LOW,30);
Var8:=HHV(Var6,30);
Var9:=MA(IF(LOW<=Var7,(Var6+Var8*2)/2,0),N);
VarA:=(2*CLOSE+HIGH+LOW)/4;
VarB:=LLV(LOW,34);
VarC:=HHV(HIGH,34);
VarD:=EMA((VarA-VarB)/(VarC-VarB)*100,6);
VarE:=EMA(0.667*REF(VarD,1)+0.333*VarD,4);
VarF:=LLV(LOW,120);
Var10:=HHV(HIGH,120);
Var11:=Var10-VarF;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VarD>VarE,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0) OR Var9>40000,LOW,'★注意买进'),colorred , ;
Var12:=MA(CLOSE,5);
英雄无敌A: MA(CLOSE,10);
Var13:=MA(CLOSE,30);
Var14:=MA(CLOSE,60);
英雄无敌B: (EMA(CLOSE,N1)*7+EMA(CLOSE,N2)*3)/10;
英雄无敌C: DMA(EMA(CLOSE,N3),SUM(VOL/CAPITAL,5)/3);
Var15:=REF(CLOSE,1);
Var16:=SMA(MAX(CLOSE-Var15,0),6,1)/SMA(ABS(CLOSE-Var15),6,1)*100;
Var17:=REF(CLOSE,1);
Var18:=SMA(MAX(CLOSE-Var17,0),6,1)/SMA(ABS(CLOSE-Var17),6,1)*100;
DRAWTEXT(CROSS(84,Var16) AND CROSS(84,Var18),HIGH,'☆注意卖出'),colorgreen , ;
STICKLINE(英雄无敌B>英雄无敌A,英雄无敌A,英雄无敌B,0.1,1);
STICKLINE(英雄无敌B<英雄无敌A,英雄无敌A,英雄无敌B,0.1,1);
回复 支持 反对

使用道具 举报

64#
 楼主| 发表于 2004-10-5 12:18:52 | 只看该作者
技术指标公式:慢速关注 缺省周期:日线}
{参数描述: N(3,100,18)M(3,100,8)M1(1,20,4)}
Var1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
Var2:=SMA(Var1,M1,1);
卖线: SMA(Var2,M1,1), , ;
Var3:=(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M))*100;
Var4:=SMA(Var3,M1,1);
Var5:=SMA(Var4,M1,1);
买入线: SMA(Var5,M1,1);
必卖线: SMA(卖线,M1,1);
高压线: 85, , ;
触底线: 9, , ;
DRAWTEXT(买入线>76.5 AND CROSS(卖线,必卖线),必卖线*1.15,'进!'), , ;
DRAWTEXT(买入线>56 AND 买入线<=76 AND CROSS(卖线,必卖线),卖线,'留意'), , ;
DRAWTEXT(买入线<45 AND 卖线>78 AND 必卖线>78 AND CROSS(必卖线,卖线),必卖线,'跑'),colorgreen , ;
DRAWTEXT(CROSS(买入线,78.5),买入线,'关注!'),colorred ,;
DRAWTEXT(CROSS(买入线,85),买入线,'重点关注!!!'),colorwhite , ;

技术指标公式:F-YZF 缺省周期:日线 实战家的YJF}
{参数描述: m1(1,200,13)m2(1,100,3)m3(1,200,13)}
Z001:=SMA(Vol,5,1);
Z002:=(Z001-llv(Z001,10))/(hhv(Z001,10)-llv(Z001,10))*100;
Z003:=SMA(Z002,3,1);
Z004:=100-Z003;
Z005:=REF(Z004,1)>REF(Z004,2) AND Z004<34;
Z006:=(CLOSE-LLV(LOW,m1))/(HHV(HIGH,m1)-LLV(LOW,m1))*100;
sss:abs(SMA(Z006,m2,1)*8-100),STICK, COLORffffff;
zzz:SMA(Z006,m3,1)*8-100,STICK, COLORred;
回复 支持 反对

使用道具 举报

65#
 楼主| 发表于 2004-10-5 12:19:15 | 只看该作者
新超跌反弹}
cyc13:="cyc@cyc13";
cyc34:="cyc@cyc34";
maxcyc:="cyc@cycmax";
CYS13:=(C-CYC13)/CYC13*100;
CYS34:=(C-CYC34)/CYC34*100;
maxCYS:=(C-maxCYC)/maxCYC*100;
市场亏损程度:
if(cys13<=-7,7,0),colorwhite,stick,linethick3;
if(cys13<=-10,10,0),colorffff33,stick,linethick3;
if(cys13<=-16,16,0),colorblue,stick,linethick3;
if(cys13<=-20,20,0),color00ff00,stick,linethick3;
if(cys13<=-25,25,0),coloryellow,stick,linethick3;
if(cys13<=-30,30,0),colorff00ff,stick,linethick3;
Var1:=COST(10)*0;
Var2:=REF(HIGH,1)*1.1;
Var3:=HIGH*1.1;
Var4:=(Var3*VOL+Var2*(CAPITAL-VOL))/CAPITAL;
Var5:=REF(LOW,1)*0.9;
Var6:=LOW*0.9;
Var7:=(Var6*VOL+Var5*(CAPITAL-VOL))/CAPITAL;
Var8:=EMA(Var7,30);
Var9:=EMA(Var4,30);
VarA:=Var9-2;
VarB:=IF(CLOSE<=Var8,VarA,Var9);
超跌: VarB*2.5,color00ff00;
TAO:=100*(1-winner(c));
a:=1.1*c;
b:=0.9*c;
ASR:=100*(winner(a)-winner(b));
筹码超跌:if((ASR<10) and (TAO>90),25,0),color0099ff;
短中长线超跌:if((CYS13<(-16)) and (CYS13>(-100)) and (CYS34<(-20)) and (CYS34>(-100)),30,0),colorddddff;
if((CYS34<(-20)) and (CYS34>(-100)) and (maxCYS<(-30)) and (maxCYS>(-100)),35,0),colorred;
反弹: VarA*2.5,colorff00ff;
var10:=REF(CLOSE,1.5);
var11:=SMA(MAX(CLOSE-var10,0),6,1)/SMA(ABS(CLOSE-var10),6,1)*100;
逃顶:IF((REF(var11,1)>80) and (var11<79),超跌,0),coloryellow;
回复 支持 反对

使用道具 举报

66#
 楼主| 发表于 2004-10-5 12:19:43 | 只看该作者
YEMA抄底逃 n=20
Var1:="BI01$VOL"*"BI01$CLOSE";
Var2:=EMA(Var1,5)/EMA("BI01$VOL",5);
CYS:=("BI01$CLOSE"-Var2)/Var2*100;
var3:=cys<= -2.33 and cys> -100;
大盘抄底准备:SUM(var3>0,N)/SUM(var3=0,N)*100;
Var4:=cross(MA(INDEXV,31),ma(INDEXV,2));
1=llv(INDEXl,60);
大盘逃顶:if(INDEXc>lo*(1+0.15) ,var4*10,0);

不死之春
m1=30
Var1:=100*VOL/CAPITAL;
Var2:=DMA(COST(10),Var1*10);
Var3:=DMA(COST(90),Var1*10);
Var4:=EMA(COST(90),30);
Var5:=DMA(COST(10),WINNER(CLOSE));
Var5-Var2;
Var3-Var4;
Var3-Var4, STICK;
Var5-Var2, STICK;
BG: (CLOSE-(Var4+Var5)/2)*0.5;
回复 支持 反对

使用道具 举报

67#
 楼主| 发表于 2004-10-5 12:20:07 | 只看该作者
鬼倒数浪通道
参数依次为:10,2,20
SARA:=SAR(N,STEP,MAXP);
数浪:SUM(SGN(SARA-REF(SARA,1)),0);
中轴:MA(数浪,8);
上轨: 中轴+3,;
下轨: 中轴-3,;
易股小叶礼物
a:=backset(ref(h,2)=hhv(h,5),3);
aa:=cross(a,0.9);
b:=backset(ref(l,2)=llv(l,5),3);
bb:=cross(b,0.9);
stickline(aa,h,h*1.01,5,0)colorgreen;
stickline(bb,l,l*0.99,5,0)colorgreen;
jj:=if(aa,h,if(bb,l,0));
POLYLINE(jj,jj )colorwhite;
a1:=backset(ref(h,2)=hhv(h,5) and l<ref(l,1) and h<ref(h,1)
{and ref(l,1)<ref(l,2)},3);
a2:=backset(ref(h,2)=hhv(h,5) and l>ref(l,1) and h>ref(h,1)
{and ref(l,1)<ref(l,2)},3);
a3:=backset(ref(h,2)=hhv(h,5) and h<ref(h,1) and l>ref(l,1)
and ref(l,1)>ref(l,2) and ref(h,1)<ref(h,2),3);
b1:=backset(ref(l,2)=llv(l,5) and l>ref(l,1) and h>ref(h,1)
{and ref(h,1)>ref(h,2)},3);
b2:=backset(ref(l,2)=llv(l,5) and l<ref(l,1) and h<ref(h,1)
{and ref(h,1)>ref(h,2)},3);
b3:=backset(ref(l,2)=llv(l,5) and h<ref(h,1) and l>ref(l,1)
and ref(l,1)>ref(l,2) and ref(h,1)<ref(h,2),3);
坚定:stickline(cross(a1,0.9),h,h*1.01,5,0)colorred;
stickline(cross(b1,0.9),l,l*0.99,5,0)colorred;
犹豫:stickline(cross(a2,0.9),h,h*1.01,5,0)coloryellow;
stickline(cross(b2,0.9),l,l*0.99,5,0)coloryellow;
等待:stickline(cross(a3,0.9),h,h*1.01,5,0)colorblue;
stickline(cross(b3,0.9),l,l*0.99,5,0)colorblue;
压力:ref(h,barslast(aa))pointdot;
stickline(c,ref(h,BARSLAST(aa)),ref(h,BARSLAST(aa)),5,0);
支撑:ref(l,barslast(bb))pointdot;
stickline(c,ref(l,BARSLAST(bb)),ref(l,BARSLAST(bb)),5,0);
stickline(c,h,l,1,0)colorcyan;
stickline(c,c,c,3,0)colorcyan;
回复 支持 反对

使用道具 举报

68#
 楼主| 发表于 2004-10-5 12:20:30 | 只看该作者
子动力

b0:=100*v/capital;
a0:=winner(c);
a1:=winner(o);

d0:=sum(if(c>o,a0*b0,0),10);
k0:=sum(if(c<=o,a1*b0,0),10);
STICKLINE(d0>0,0,d0,5,0),COLOR00FFFF;{黄色}
STICKLINE(d0>0,0,d0*0.85,5,0),COLOR00DDFF;
STICKLINE(d0>0,0,d0*0.75,5,0),COLOR00BBFF;
STICKLINE(d0>0,0,d0*0.65,5,0),COLOR0099FF;
STICKLINE(d0>0,0,d0*0.55,5,0),COLOR0077FF;
STICKLINE(d0>0,0,d0*0.45,5,0),COLOR0055FF;
STICKLINE(d0>0,0,d0*0.35,5,0),COLOR0033FF;
STICKLINE(d0>0,0,d0*0.25,5,0),COLOR0011FF;
STICKLINE(k0>0,0,k0,5,0),COLOR66FF00;{翠绿}
STICKLINE(k0>0,0,k0*0.85,5,0),COLOR66DD00;
STICKLINE(k0>0,0,k0*0.75,5,0),COLOR66BB00;
STICKLINE(k0,0,k0*0.65,5,0),COLOR669900;
STICKLINE(k0>0,0,k0*0.55,5,0),COLOR667700;
STICKLINE(k0>0,0,k0*0.45,5,0),COLOR665500;
STICKLINE(k0>0,0,k0*0.35,5,0),COLOR663300;
{STICKLINE(k0>0,0,k0*0.25,5,0),COLOR661100;}
Var2:=LLV(LOW,10);
Var3:=HHV(HIGH,25);
动力线1: dma(d0,EMA((CLOSE-Var2)/(Var3-Var2)*4,4)) colorwhite,linethick2
回复 支持 反对

使用道具 举报

69#
 楼主| 发表于 2004-10-5 12:20:56 | 只看该作者
波段是金
鱼:ema((c+l+h)/3,3);
浅水:ema(ema((c+l+h)/3,3),26),colorgreen,linethick2;
zz:=eMA(CLOSE,26);
钓:zz+ 2*STD(CLOSE,26)+zz+ 2*STD(CLOSE,49))/2,colorred,linethick2;
a8:=abs(EMA(CLOSE,100)-EMA(CLOSE,10))/ema((c+l+h)/3,3)*c*2+ema((c+l+h)/3,3);
a9:=abs(EMA(CLOSE,100)-EMA(CLOSE,10))/ema((c+l+h)/3,3)*c+ema((c+l+h)/3,3);
饵:a8,coloryellow,linethick2;
海底:ema(ema((c+l+h)/3,3),26)*0.88,colorffbb44,linethick2;
STICKLINE( low<海底,海底-c*0.015 ,海底+c*0.015 ,8 ,1 ),colorffbb44;
回复 支持 反对

使用道具 举报

70#
 楼主| 发表于 2004-10-5 12:21:24 | 只看该作者
铂金趋势

Var2:=(CLOSE*2+HIGH+LOW)/4;
Var3:=EMA(Var2,3);
Var4:=EMA(Var3,6);
L1: EMA(Var2,3), , ;
L2: EMA(Var3,4), , ;
L3: EMA(Var4,5), , ;
STICKLINE(L1>=L2,HIGH,LOW,6,0) COLORRED;
STICKLINE(L1Var5:=REF(L1,1)>L1 AND L1>L2;
Var6:=L1>L2 AND CLOSESTICKLINE(Var5,HIGH,LOW,6,0) COLORBLUE;
Var7:=AMOUNT/10000;
Var8:=Var7/MA(Var7,5);
Var9:=VOL/FINANCE(7);
VarA:=Var8>2 AND REF(Var8>1,1) AND REF(Var8>1,2);
VarB:=Var9>5 AND REF(Var8>1,1) OR Var9>5 AND Var8>1 OR Var9>4 AND Var8>2;
STICKLINE(L1>L3 AND CROSS(L1,L3) AND (VarA OR VarB),OPEN-0.8,OPEN-1,6,0), , COLORYELLOW;
VarC:=CLOSE-REF(MA(CLOSE,21),1);
VarD:=EMA(VarC-MA(VarC,21),5);
VarE:=SMA(VarC,7,1);
VarF:=CROSS(VarC,VarE) AND VarE<-1;
STICKLINE(VarF,OPEN-0.5,OPEN-0.7,6,0), , COLORYELLOW;
回复 支持 反对

使用道具 举报

71#
 楼主| 发表于 2004-10-5 12:22:33 | 只看该作者
天龙八部1}
MID:=FORCAST(CLOSE,11);
上轨:=MID*1.025;
下轨:=MID*0.975;
极限:=(C-下轨)/(上轨-下轨)*100;
波动因子:MA(极限-REF(极限,1),3)+50,COLOR00FF00;
【波动极限】:50,COLORWHITE;

{天龙八部2}
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
D:=SMA(CCC,3,1);
【逃顶至尊1】:if(CROSS(D,RSI5),50,0),STICK,COLORMAGENTA;
【逃顶至尊2】:if(CROSS(80,RSI5),-50,0),STICK,COLORGREEN;
STICKLINE(CROSS(D,RSI5),50,0,6,0),COLORMAGENTA;
STICKLINE(CROSS(80,RSI5),-50,0,6,0),COLORGREEN;
回复 支持 反对

使用道具 举报

72#
 楼主| 发表于 2004-10-5 12:22:56 | 只看该作者
超级通道
P2 50 200 130

Var1:=IF(YEAR>2999 AND MONTH>5,0,1);
Var2:=IF(HIGH=CLOSE,1.07*CLOSE,HIGH)*Var1;
Var3:=IF(HIGH=CLOSE,0.93*CLOSE,LOW)*Var1;
Var4:=(REF(CLOSE,1)+REF(LOW,1)+REF(HIGH,1)+REF(OPEN,1))/4;
Var5:=IF(REF(LOW,1)=REF(HIGH,1),1.1*REF(CLOSE,1),Var4)-REF(LOW,1);
CC1: EMA(EMA(Var2,6)*1.14,8);
DN: REF(CLOSE,1)-Var5;
NP: REF(CLOSE,1)+Var5;
DD1: EMA(EMA(Var3,6)*0.96,8);
Var6:=EMA((CC1+DD1)/2,5);
Var7:=SAR(8,2,20);
Var8:=MA(CLOSE,P2);
Var9:=Var8+1.85*STD(CLOSE,P2);
VarA:=Var8-1.85*STD(CLOSE,P2);
回复 支持 反对

使用道具 举报

73#
 楼主| 发表于 2004-10-5 12:23:17 | 只看该作者
成本+铁底

a:=(3*c+l+o+h)/6;
X20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210,COLORMAGENTA,linethick2,pointdot;
Y:MA(X,15),COLORWHITE,linethick2,pointdot;
DRAWTEXT(XDRAWTEXT(X>Y AND REF(X>Y,1)=0,X-0.5,'↑')COLORGREEN,linethick7;
Var4:=(2*CLOSE+HIGH+LOW)/4;
成本区:EMA(Var4,90)*0.995,COLORGREEN,circledot;
操作区:EMA(Var4,142)*0.998,COLORRED,,linethick2;
铁底区:EMA(Var4,250)*0.885,COLORYELLOW,linethick2;
回复 支持 反对

使用道具 举报

74#
 楼主| 发表于 2004-10-5 12:23:34 | 只看该作者
百分比带
中轨:ema(c,21),pointdot;
上轨:ema(c,21)*1.05,linethick2;
下轨:ema(c,21)/1.05,linethick2;
STICKLINE(REF(中轨,1)<中轨,中轨,REF(中轨,1),3,0),linethick2,COLORMAGENTA;
STICKLINE(REF(中轨,1)>中轨,中轨,REF(中轨,1),3,0),linethick2,COLORCYAN;

回复 支持 反对

使用道具 举报

75#
 楼主| 发表于 2004-10-5 12:23:57 | 只看该作者
百分比线
N1 0 100 3
N2 0 300 20

TD:=DATE="EZSTOCK@TDATE" ;
MAA:MA(CLOSE,N1),COLOR00FFFF;
RSV3:=HHV(HIGH,N2);
RSV6:=LLV(LOW,N2);
Var1:=RSV3-RSV6;
HHH:RSV3,COLORWHITE;
HHH-Var1*0.125,POINTDOT,COLORYELLOW;
HHH-Var1*0.25,POINTDOT,COLORWHITE;
HHH-Var1*0.333,POINTDOT,COLORYELLOW;
HHH-Var1*0.375,POINTDOT,COLORWHITE;
HHH-Var1*0.5,POINTDOT,COLORYELLOW;
HHH-Var1*0.625,POINTDOT,COLORWHITE;
HHH-Var1*0.667,POINTDOT,COLORYELLOW;
HHH-Var1*0.75,POINTDOT,COLORWHITE;
HHH-Var1*0.875,POINTDOT,COLORYELLOW;
LLL:RSV6,COLORWHITE;


Var2:=DRAWTEXT(TD>0,HHH-Var1*0.125,'跌12.5'),COLORGREEN;
Var3:=DRAWTEXT(TD>0,HHH-Var1*0.25,'跌25.0'),COLORGREEN;
Var4:=DRAWTEXT(TD>0,HHH-Var1*0.333,'跌33.3'),COLORGREEN;
Var5:=DRAWTEXT(TD>0,HHH-Var1*0.375,'跌37.5'),COLORGREEN;
Var6:=DRAWTEXT(TD>0,HHH-Var1*0.5,'跌50.0'),COLORGREEN;
Var7:=DRAWTEXT(TD>0,HHH-Var1*0.625,'跌62.5'),COLORGREEN;
Var8:=DRAWTEXT(TD>0,HHH-Var1*0.667,'跌66.7'),COLORGREEN;
Var9:=DRAWTEXT(TD>0,HHH-Var1*0.75,'跌75.0'),COLORGREEN;
DRAWTEXT(TD>0,HHH-Var1*0.875,'跌87.5'),COLORGREEN;
Var12:=DRAWTEXT(TD>0,HHH-Var1*0.125,' 涨87.5'),COLOR0000FF;
Var13:=DRAWTEXT(TD>0,HHH-Var1*0.25,' 涨75.0'),COLOR0000FF;
Var14:=DRAWTEXT(TD>0,HHH-Var1*0.333,' 涨66.7'),COLOR0000FF;
Var15:=DRAWTEXT(TD>0,HHH-Var1*0.375,' 涨62.5'),COLOR0000FF;
Var16:=DRAWTEXT(TD>0,HHH-Var1*0.5,' 涨50.0'),COLOR0000FF;
Var17:=DRAWTEXT(TD>0,HHH-Var1*0.625,' 涨37.5'),COLOR0000FF;
Var18:=DRAWTEXT(TD>0,HHH-Var1*0.667,' 涨33.3'),COLOR0000FF;
Var19:=DRAWTEXT(TD>0,HHH-Var1*0.75,' 涨25.0'),COLOR0000FF;
DRAWTEXT(TD>0,HHH-Var1*0.875,' 涨12.5'),COLOR0000FF;
回复 支持 反对

使用道具 举报

76#
 楼主| 发表于 2004-10-5 12:24:32 | 只看该作者
变动空间
N 2 2 2
N1 1 15 15
N2 1 100 51
N3 13 13 13

巫山会员专用版RAWTEXT( MONTH =1 and DATE=4,c,'巫山会员专用版');
中轨:=SQRT(SQRT(l*h*open*c)) color00ff00 ;
超买:=SMA(AMOUNT/VOL/100,N3,1)*1.21, linethick2;
VAR51:= EMA(中轨,N2),pointdot,colorwhite;
VAR519:= EMA(中轨,21),pointdot,colorwhite;
VAR41:= EMA(中轨,N1),pointdot,colorwhite;
主线:= EMA(VAR51,N2)linethick2,colorffffff;
主线1:= EMA(VAR519,8)linethick2,colorffffff;
STICKLINE(VAR41>VAR51,主线1,ref(主线1,1),5,0),colorred;
STICKLINE(VAR41

DRAWICON(CROSS(VAR51,VAR41),主线1,2);
DRAWICON(CROSS(VAR41,VAR51),主线1,1);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),25,1)/SMA(ABS(CLOSE-LC),25,1)*100;
dy:=BARSCOUNT(rsi1>50)>55;
var2z:=(c-open)/open>0.02 and dy;
var3z:=ref(low,2)<=cost(0) or ref(low,1)<=cost(0);
var4z:= ma((llv(low,45)-close)/(hhv(high,45)-llv(low,45))*100,5);
var5z:=cross(-5,var4z);
var6z:=BARSLAST(var5z=1)<=5;
var1:=ref(rsi1,1)< 35 and rsi1>ref(rsi1,1) and var2z and var3z and var6z;
var101:=FILTER(var1,20);
中价:=SQRT(llv(l,13)*hhv(h,13));
linethick2 目标位:=ref(hhv(high,34),21)*10/9,color00ff00;

变动空间:linethick2 ref(hhv(high,91.3),13)*10/9.193,color9999ff;
初级变动空间:linethick2 ref(hhv(high,34),8)*10/9.67,colorccccff;
熊市支撑:linethick2 SQRT( ref(llv(l,34),34)*ref(hhv(h,34),34))*0.618,color338833;
牛市支撑:linethick2 SQRT( ref(llv(l,34),13)*ref(hhv(h,34),13))*0.618*1.382,color559999;
drawtext(FILTER(ref(c,1)<牛市支撑 and c>牛市支撑 ,20),c,'有机会'),coloryellow;
drawtext(FILTER(ref(l,1)<熊市支撑 and c>熊市支撑,5 ),c,'可以了'),coloryellow;
vary:=ref(cross(目标位,c),3)and c<目标位;


var001:=ref(cross(变动空间,c ),1)and c<变动空间 ;
var002:= ref(cross(h,变动空间),1)and c<变动空间;

var0011:=ref(cross(初级变动空间,c ),1)and c<初级变动空间 ;
var0021:= ref(cross(h,初级变动空间),1)and c<初级变动空间;
DRAWTEXT( var0011 or var0021 or var001 or var002,h ,'注意' ),coloryellow;

drawtext(var1=1 and var001< 1 and var002<1,h,'☆快买'),coloryellow;
DRAWTEXT( FILTER(vary ,5),h ,'注意' ),coloryellow;
Var1p:=INDEXC;
Var2p:=MA(Var1p,6);
Var3p:=MA(Var1p,24);
Var4p:=MA(Var1p,32);
Var5p:=MA(Var1p,62);
Var6p:=MA(Var1p,105);
Var7p:=Var5pVar8p:=Var4p>Var2p*1.11 AND Var3p>Var2p*1.095;
Var9p:=Var2p>Var1p*0.95;
var10p:=Var7p AND Var8p AND Var9p AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSEREF(OPEN,1)
OR REF(CLOSE,1)


drawtext(FILTER( var10p=1,5 ) ,h,'☆快买'),coloryellow;
Va1:=1;
Va2:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100*Va1;
空:=sMA(Va2,3,1)*Va1,colorblue ,;
Va3:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100*Va1;
短:= sma(sMA(Va3,2,1)+3*Va1,2,1) , ;

庄家:=WINNER(ma(CLOSE,5))*100,;
Var1g:=(HHV(HIGH,9)-LLV(LOW,9));
Var2g:=(HHV(HIGH,9)-CLOSE);
Var3g:=(CLOSE-LLV(LOW,9));
Var4g:=Var2g/Var1g*100-70 ;
Var5g:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6g:=(2*C+H+L)/4;
Var7g:=SMA((Var3g/Var1g*100),3,1);
Var8g:=LLV(LOW,26);
Var9g:=SMA(Var7g,3,1)-SMA(Var4g,9,1);
Var10g:= IF(Var9g>100,Var9g-100,0);
VarAg:=HHV(HIGH,34);
B:=EMA((Var6g-Var8g)/(VarAg-Var8g)*100,16),COLORCYAN;
浮:=EMA(B,4),colorgreen,linethick2;
d:=LLVBARS(ma(c,5),30);
压力线:=if(35+ema(浮,80)<100,35+ema(浮,80),100),colorred,CIRCLEDOT linethick1;
庄家生命:=WINNER(ma(CLOSE,5))*100,colorcc33cc;
短线:= sma(sMA(Va3,2,1)+3*Va1,2,1) , coloryellow;
浮筹:=EMA(B,4),colorgreen,linethick2;
空方:= sMA(Va2,3,1)*Va1,colorblue ,;
DRAWTEXT(FILTER(cross(浮筹,空方) and 浮筹<50 ,13 ),c,'还有一波'),colorwhite

回复 支持 反对

使用道具 举报

77#
 楼主| 发表于 2004-10-5 12:24:57 | 只看该作者
冰枫看盘
MA13: MA(CLOSE,13);
MA21: MA(CLOSE,21);
年线: MA(CLOSE,250);
底部线: EMA(COST(3.5),10);
s:=MA(VOL,5)/MA(VOL,60),colorred,,linethick2;
a:=ma(s,5),colorgreen,,linethick2;
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
f:=ma(s,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1);
D:=SMA(K,15,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH,'→ 逃顶 '),COLORYELLOW ;
DRAWTEXT(CROSS(RSI,11) , LOW,'→ 低吸 '),COLORRED ;
MID := MA(CLOSE,26);
UPPER:= MID + 2*STD(CLOSE,26);
LOWER:= MID - 2*STD(CLOSE,26);
s1:=IF((j<11 and BIAS>-11 and cross( s,f) and (s-f)>0.010),2,0),stick,linethick3,colorgreen;
DRAWTEXT(s1=2,LOW,'→关注 '), colorgreen;
DRAWICON( FILTER(cross(s,a) and a<0.5 and j<20,13),LOW,1 );
回复 支持 反对

使用道具 举报

78#
 楼主| 发表于 2004-10-5 12:25:21 | 只看该作者
波段操作2
年 1 1111 216
月 1 1111 13
日 1 1111 4

Var1:=0;
Var2:=IF(DATE>Var1,1,0);
日线: MA(CLOSE,日);
周线: MA(CLOSE,13);
月线: MA(CLOSE,月);
半年线: MA(CLOSE,108);
年线: MA(CLOSE,年);
M377: MA(CLOSE,377);
Var3:=(LOW+HIGH+CLOSE)/3;
Var4:=IF(Var2,0,MA(Var3,5));
Var5:=IF(Var2,0,HHV(Var4,13));
Var6:=IF(Var2,0,HHV(Var4,60));
Var7:=IF(Var2,0,LLV(Var4,13));
Var8:=IF(Var2,0,LLV(LOW,60))*1.02;
Var9:=IF(Var2,0,HHV(HIGH,60))*0.98;
DRAWTEXT(CROSS(Var8,Var7),LOW,'小顶'),COLORMAGENTA;
VarA:=EMA(WINNER(COST(50)),4)*Var2;
VarB:=EMA(WINNER(CLOSE),4)-VarA;
VarC:=EMA(VarB,8)*Var2;
VarD:=2*(VarB-VarC)*Var2;
VarE:=3*VarB-2*VarC*Var2;
DRAWTEXT(CROSS(VarE,0) OR CROSS(VarE,-0.335),CLOSE,'压力')*Var2,COLORYELLOW;
DRAWTEXT(CROSS(VarE,0.249),HIGH,'冲顶')*Var2, COLORCYAN, ;
DRAWTEXT(CROSS(VarE,0.524),CLOSE,'小顶')*Var2, , COLORMAGENTA ;
DRAWTEXT(CROSS(VarE,0.58),HIGH,'顶部')*Var2, COLORRED, ;
DRAWTEXT(CROSS(0.81,VarE),OPEN,'大顶')*Var2, COLORRED, ;
DRAWTEXT(CROSS(VarE,-0.515),CLOSE,'买')*Var2,COLORGREEN , ;
VarF:=LLV(LOW,36)*Var2;
Var10:=HHV(HIGH,30)*Var2;
Var11:=EMA((CLOSE-VarF)/(Var10-VarF)*4,4)*25*Var2;
Var12:=(Var11-LLV(Var11,4))/(HHV(Var11,4)-LLV(Var11,4))*4*25*Var2;
Var13:=CROSS(Var12,87.5) AND Var11<40;
DRAWTEXT(CROSS(VarE,-0.5) AND Var13,(LOW+HIGH)/2,'底买')*Var2, COLORGREEN, ;
DRAWTEXT(CROSS(VarE,-0.638) OR CROSS(VarE,-0.57) OR CROSS(VarE,-0.478),LOW-0.1,'反弹')*Var2, COLORWHITE, ;

回复 支持 反对

使用道具 举报

79#
 楼主| 发表于 2004-10-5 12:25:43 | 只看该作者
条件选股公式:1黄金白银 (成功率:93.99%=2248=利润1总平均:33.03% ) 缺省周期:日线
=======================================================================================
参数描述: 跌速(-50,0,-30)涨(-5,10,8)统计(1,20,10)备用(-5,10,3)
=======================================================================================
Var1:=IF(DATE>=1021231,0,1);
Var2:=(CLOSE-REF(OPEN,19))/REF(OPEN,19)*100*Var1;
Var3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100*Var1;
Var4:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100*Var1;
Var5:=LWINNER(100,CLOSE)*100;
Var6:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100*Var1;
Var7:=SMA(Var6,3,1);
Var8:=SMA(Var7,3,1);
Var9:=3*Var7-2*Var8;
VarA:=COUNT(CROSS(Var7,Var8) AND Var8<8 AND Var3>涨 AND Var4<跌速,统计)*Var1;
VarA OR VarA AND Var3<备用*Var1;
回复 支持 反对

使用道具 举报

80#
发表于 2004-10-5 12:25:47 | 只看该作者
ok
回复 支持 反对

使用道具 举报

81#
发表于 2004-10-5 12:26:04 | 只看该作者
DDDDDDDDDDDDDDD
回复 支持 反对

使用道具 举报

82#
 楼主| 发表于 2004-10-5 12:26:26 | 只看该作者
动能彩量

Var1:=HIGH-LOW;
Var2:=ABS(OPEN-CLOSE);
Var3:=HIGH-IF(CLOSE>OPEN,CLOSE,OPEN);
Var4:=IF(CLOSE>OPEN,OPEN,CLOSE)-LOW;
Var5:=Var2/Var1*VOL;
Var6:=Var3/Var1*VOL;
Var7:=Var4/Var1*VOL;
Var8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))));
MA5: MA(VOL,5), , COLORRED;
MA10: MA(VOL,10), , COLORGREEN;
多头成交口: STICKLINE(CLOSE>MA(CLOSE,30),0,VOL,8,1), , COLORRED;
空头成交口: STICKLINE(CLOSE<MA(CLOSE,30),0,VOL,8,1), , COLORGREEN;
向上攻击量: STICKLINE(Var5>=Var6 AND Var5>=Var7 AND CLOSE>OPEN,0,Var5,8,0), , COLORRED;
向下攻击量: STICKLINE(Var5>=Var6 AND Var5>=Var7 AND CLOSE<OPEN,0,Var5,8,0), , COLORGREEN;
上探量: STICKLINE(Var6>Var5 AND Var6>Var7,0,Var6,8,0), , COLORCCCC66;
下探量: STICKLINE(Var7>Var5 AND Var7>Var6,0,Var7,8,0), , COLORFF6633;
相对地量: STICKLINE(Var8>2 AND VOL<MA(VOL,5)/2,0,VOL,2.5,0), , COLORMAGENTA;
放量: STICKLINE(VOL>MA(VOL,5)*3,0,VOL,2.5,0), , COLORWHITE;
逢高出货: DRAWTEXT(Var6>Var5 AND Var6>Var7 AND CLOSE>MA(CLOSE,5)
AND CLOSE>MA(CLOSE,30) AND HIGH>MA(CLOSE,60) AND VOL>MA5
AND Var6>MA(VOL,5),VOL,'逢高出货'), , COLORRED;

回复 支持 反对

使用道具 举报

83#
 楼主| 发表于 2004-10-5 12:27:12 | 只看该作者
易股搜牛--主图)

搜牛趋势:HHV(MA((L+H+C)/3,3),1),colorff00ff,linethick2;
上轨: HHV(MA((L+H+C)/3,8),58),color006666,linethick2;
搜牛轨道1:llv(MA((L+H+C)/3,3),10),colorblue,linethick2;
下轨: llv(MA((L+H+C)/3,8),58),color009999,linethick2;
A1:=ma( MA((L+H+C)/3,1),5);
A2:=REVERSE((H+L+C)/3)+2*A1;
A3:=3*A2-2*sma(A2,3,1),color009900;
搜牛短线:if(A3<A2,A2,A3),color009900;
STICKLINE(搜牛短线>搜牛趋势,搜牛趋势,搜牛短线,0.5,0),colorblue
回复 支持 反对

使用道具 举报

84#
 楼主| 发表于 2004-10-5 12:28:02 | 只看该作者
均线密集
{真正的均线密集可以从不同方向挤出来}
a1:=hhv(h,15) ;
a2:=llv(l,15) ;

kk0:llv(l,15)+((a1-a2)/2) ;
kk1:ma(kk0,5);
kk2:ma(kk0,10);
kk3:ma(kk0,120) colorwhite;

动向
Var1:=IF(YEAR>=2002 AND MONTH>2,0,1);
Var2:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100*Var1;
Var3:=SMA(Var2,3,1)*Var1;
Var4:=SMA(Var3,3,1)*Var1;
Var5:=LLV(LOW,5)*Var1;
Var6:=HHV(HIGH,3)*Var1;
Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,3)*Var1;
Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2)*Var1;
Var9:=SMA(Var4,3,1)*Var1;
VarA:=SMA(Var4,3,1)*Var1;
VarB:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100*Var1;
VarC:=SMA(VarB,6,1)*Var1;
VarD:=SMA(VarC,34,1)*Var1;
VarE:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100*Var1;
VarF:=(SMA(VarB,3,1)-18)*1.55*Var1;
Var10:=SMA(VarC,3,1)*Var1;
Var11:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100*Var1;
Var12:=SMA(VarB,10,1)*Var1;
Var13:=(EMA(SMA(VarC,8,1),34)-23)*2.6*Var1;
Var14:=COST(10);
Var15:=(CLOSE-Var14)/Var14*100;
Var16:=COUNT(Var15<-2.05,3)*Var1;
Var17:=(IF(WINNER(1.1*CLOSE)<0,0,WINNER(1.1*CLOSE))-IF(WINNER(0.9*CLOSE)<0,0,WINNER(0.9*CLOSE)))*100*Var1;
Var18:=BARSCOUNT(CLOSE);
Var19:=IF(Var18>30,30,Var18);
Var1A:=IF(Var18>120,120,Var18);
Var1B:=SUM(AMOUNT,Var19);
Var1C:=SUM(AMOUNT,Var1A);
Var1D:=IF(Var6<0,0,Var6)*Var1;
Var1E:=IF(Var17<0,0,Var17)*Var1;
Var1F:=100*Var1B/Var1C*Var1;
Var20:=Var13*Var1;
主力动向1: PWINVER(10,Var1D)*Var1, , [00040001];
主力动向2: PWINVER(10,Var1F)*Var1, , [00040001];
主力动向3震仓: PWINVER(10,Var1E)*Var1, , [00050001];
Var21:=COST(10)*Var1;
Var22:=(CLOSE-Var21)/Var21*100*Var1;
Var23:=COUNT(Var22<-2.05,3)*Var1;
主力蓄势大本营: IF(Var23>=3,0.06,0)*Var1, , [00050001];
风险区域: 1, , [00010001];
0.9*Var1, , [00010001];
Var24:=(CLOSE-MA(CLOSE,10))/STD(CLOSE,35)*0.3*Var1;
强弱动向: EMA(Var24,18)*Var1, , [00040003];
回复 支持 反对

使用道具 举报

85#
 楼主| 发表于 2004-10-5 12:28:25 | 只看该作者
生命
Var1:=IF(YEAR>=2002 AND MONTH>3,0,1);
Var2:=N2*N3/(N1*N2+N1*N3+N2*N3)*Var1;
Var3:=N1*N3/(N1*N2+N1*N3+N2*N3)*Var1;
Var4:=N1*N2/(N1*N2+N1*N3+N2*N3);
Var5:=Var2*MA(CLOSE,N1)+Var3*MA(CLOSE,N2)+Var4*MA(CLOSE,N3)*Var1;
Var6:=MA(CLOSE,25)+MA(CLOSE,5)/40*Var1;
Var7:=FORCAST(CLOSE,30)*Var1;
Var8:=COST(10);
Var9:=(CLOSE-Var8)/Var8*100*Var1;
VarA:=COUNT(Var9<-2.05,3)*Var1;
生命M: PWINVER(10,Var5)*Var1, , [00050001];
REVERSE(生命M)*Var1, , [00050001];
生命A: PWINVER(5,Var7)*Var1, , [00050001];
REVERSE(生命A)*Var1, , [00050001];
生命C: PWINVER(20,Var6)*Var1, , [00050001];
REVERSE(生命C)*Var1, , [00050001];
生命D: PWINVER(50,Var6)*Var1, , [00050001];
REVERSE(生命D)*Var1, , [00050001];
0.8, , [00010008];
0.4, , [00010008];
-0.8, , [00010008];
-0.4, , [00010008];
n1 5
n2 30
n3 60

回复 支持 反对

使用道具 举报

86#
 楼主| 发表于 2004-10-5 12:28:53 | 只看该作者
彩虹Var1:=IF(YEAR>=2002 AND MONTH>2,0,1);
虹1: 100*(EMA(CLOSE,21)-EMA(CLOSE,60)-EMA(EMA(CLOSE,21)-EMA(CLOSE,60),13))*Var1, , [00040001];
虹2: 100*(EMA(CLOSE,18)-EMA(CLOSE,45)-EMA(EMA(CLOSE,18)-EMA(CLOSE,45),11))*Var1, , [00040001];
虹3: 100*(EMA(CLOSE,15)-EMA(CLOSE,34)-EMA(EMA(CLOSE,15)-EMA(CLOSE,34),9))*Var1, , [00040001];
虹4: 100*(EMA(CLOSE,12)-EMA(CLOSE,26)-EMA(EMA(CLOSE,12)-EMA(CLOSE,26),6))*Var1, , [00040001];
虹5: 100*(EMA(CLOSE,5)-EMA(CLOSE,10)-EMA(EMA(CLOSE,5)-EMA(CLOSE,10),5))*Var1, , [00040001];
Var2:=(CLOSE-MA(CLOSE,10))/STD(CLOSE,35)*20;
多空: EMA(Var2,18), , [00040003];
争持位: 0;
强弱A: EMA(Var2,55), , [00050001];

回复 支持 反对

使用道具 举报

87#
 楼主| 发表于 2004-10-5 12:29:18 | 只看该作者
碎型
Y:=(H+L)/2;
BLUE:=SMA(Y,13,1),SHIFT8,COLORBLUE;

RED:=SMA(Y,8,1),SHIFT5,COLORRED;

GREEN:=SMA(Y,5,1),SHIFT3,COLORGREEN;

B2:=REF(BLUE,8);

R2:=REF(RED,5);

G2:=REF(GREEN,3);

AO:MA(Y ,5 )-MA(Y ,34 )linethick0;

AC:AO-MA( AO,5),linethick0;

AO转:=(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,SHIFT1;

AO零:=(165*ma(Y,33)-136*ma(Y,4))/29,LINETHICK0;

AC转:=(5*34*5*AO-5*34*5*MA(AO,5)+5*34*4*MA(AO,4)+5*4*33*MA(Y,33)-4*34*4*MA(Y,4))/116,LINETHICK0;

AC零:=(5*34*MA(AO,4)-34*4*MA(Y,4)+5*33*MA(Y,33))/29,SHIFT1;

KU1:=IF(H=HHV(H,3),1,0);

KD1:=IF(L=LLV(L,3),1,0);

UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF(H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));

UL2:IF(H>=R2,UL,REF(UL,BARSLAST(H>R2))),COLORMAGENTA,POINTDOT;

DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF(L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));

DL2:IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2))),COLORYELLOW,POINTDOT;

DRAWICON(H>UL2 AND REF(H,1)<REF(UL2,1),H*1.03,4);

DRAWICON(L<DL2 AND REF(L,1)>REF(DL2,1),L*0.99,5);
回复 支持 反对

使用道具 举报

88#
 楼主| 发表于 2004-10-5 12:29:52 | 只看该作者
鳄鱼线

Y:=(H+L)/2;
BLUE:=SMA(Y,13,1),SHIFT8,COLORBLUE;

RED:=SMA(Y,8,1),SHIFT5,COLORRED;

GREEN:=SMA(Y,5,1),SHIFT3,COLORGREEN;

B2:=REF(BLUE,8);

R2:=REF(RED,5);

G2:=REF(GREEN,3);

KU1:=IF(H=HHV(H,3),1,0);

KD1:=IF(L=LLV(L,3),1,0);

UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF(H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));

DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF(L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));

KU:=IF(C>B2 AND C>R2 AND C>G2,1,0);

KD:=IF(C<B2 AND C<R2 AND C<G2,-1,0);

KK:=IF(BARSLAST(KU=1 AND REF(KU,1)=0)<BARSLAST(KD=-1 AND REF(KD,1)=0),1,-1);
AO:=MA(Y ,5 )-MA(Y ,34 );

AC:=AO-MA( AO,5);
ac1:=ref(AC,1);
ao1:=ref(ao,1);
AO转170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,linethick0;

AO零165*ma(Y,33)-136*ma(Y,4))/29,linethick0;

AC转5*34*5*AO-5*34*5*MA(AO,5)+5*34*4*MA(AO,4)+5*4*33*MA(Y,33)-4*34*4*MA(Y,4))/116,linethick0;

AC零5*34*MA(AO,4)-34*4*MA(Y,4)+5*33*MA(Y,33))/29,linethick0;

KAC:=IF(AC>ac1 AND Ao>ao1,1,0);

***:=IF(AC<ac1 AND Ao<ao1,-1,0);

蓝:SMA(Y,13,1),SHIFT8,COLORBLUE;

红:SMA(Y,8,1),SHIFT5,COLORRED;

绿:SMA(Y,5,1),SHIFT3,COLORGREEN;

上碎型:IF(H>=R2,UL,REF(UL,BARSLAST(H>R2))),COLORMAGENTA,linethick0;

下碎型:IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2))),COLORYELLOW,linethick0;

STICKLINE(BARSLAST(ABS(上碎型-REF(上碎型,1)))<BARSLAST(c>上碎型 AND REF(c,1)<REF(上碎型,1)),上碎型,上碎型,3,1),COLORMAGENTA;

STICKLINE(BARSLAST(ABS(下碎型-REF(下碎型,1)))<BARSLAST(c<下碎型 AND REF(c,1)>REF(下碎型,1)),下碎型,下碎型,3,1),COLORYELLOW;

OL:=(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,shift1,color000033;
CL:=(165*ma(y,33)-136*ma(y,4)+170*(4*MA(AO,4)+5*(REF(AO,4)-MA(REF(AO,4),5)))/4)/29,shift1,color000033;

H1:=REF(H,4);
H2:=REF(H,3);
H3:=REF(H,2);
H4:=REF(H,1);
H5:=H;
L1:=REF(L,4);

L2:=REF(L,3);

L3:=REF(L,2);

L4:=REF(L,1);

L5:=L;

∥:=(H3>H2) And (H3>H1) And (H3>H4) And (H3>H5);

∥Fractal:=IF(∥,1,0);

∥Var1:=BackSet(∥Fractal,3);

∥Var2:=Filter(∥Var1,2);

∥Var3:=BackSet(∥Fractal,5);
∣:=(L3<L2) And (L3<L1) And (L3<L4) And (L3<L5);

∣Fractal:=IF(∣,1,0);

∣Var1:=BackSet(∣Fractal,3);

∣Var2:=Filter(∣Var1,2);

∣Var3:=BackSet(∣Fractal,5);

DrawIcon(∥Var2,H*1.001,'S14');

DrawIcon(∣Var2,L,'S14');
DRAWICON(c>上碎型 AND REF(c,1)<REF(上碎型,1),H*1.015,4);

DRAWICON(c<下碎型 AND REF(c,1)>REF(下碎型,1),L*0.99,5);
DRAWICON(KU=1 AND REF(KU,1)=0 and c<0,L,4);

DRAWICON(KD=-1 AND REF(KD,1)=0 and c<0,H*1.01,5);
DRAWICON(KU=0 AND REF(KU,1)=1 and c<0,H*1.01,7);

DRAWICON(KD=0 AND REF(KD,1)=-1 and c<0,L,6);

STICKLINE(KAC=1 AND C>=O,O,C,8,1),COLORRED;

STICKLINE(***=-1 AND C>=O,O,C,8,1),COLORGREEN;

STICKLINE(***=0 AND KAC=0 AND C>=O,O,C,8,1),COLORGRAY;

STICKLINE(C>=O,H,C,0.4,1),COLORRED;

STICKLINE(C>=O,O,L,0.4,1),COLORRED;

STICKLINE(KAC=1 AND C<O,O,C,8,0),COLORRED;

STICKLINE(***=-1 AND C<O,O,C,8,0),COLORGREEN;

STICKLINE(***=0 AND KAC=0 AND C<O,O,C,8,0),COLORGRAY;

STICKLINE(O>C,H,O,0.4,1),COLORCYAN;

STICKLINE(O>C,C,L,0.4,1),COLORCYAN;


DU0:=CROSS(AO,0);

UD0:=CROSS(0,AO);

TDU0:=BARSLAST(DU0);

TUD0:=BARSLAST(UD0);

DU3:=REF(DU0,1);

UD3:=REF(UD0,1);

TDU3:=BARSLAST(DU3);

TUD3:=BARSLAST(UD3);
UDGLINE:IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3)),COLORYELLOW;

JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;

JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;

JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;

JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;

JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);

JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);

DRAWTEXT(JDU2,L*0.98,'\n空\n转\n多'),align4;

DRAWTEXT(JUD2,H*1.03,'\n多\n转\n空'),align5;

DRAWTEXT(JDU3,L*0.98,'\n多\n续\n多'),align4;

DRAWTEXT(JUD3,H*1.03,'\n空\n续\n空'),align5;

BSLINE:=IF(BARSLAST(JDU2)<BARSLAST(JUD2),IF(REF(CROSS(0,AC),1) OR REF(CROSS(0,AO),1),LLV(L,2),REF(LLV(L,2),BARSLAST(REF(CROSS(0,AC),1) OR REF(CROSS(0,AO),1)))),IF(REF(CROSS(AC,0) OR REF(CROSS(AO,0),1),1),HHV(H,2),REF(HHV(H,2),BARSLAST(REF(CROSS(AC,0),1) OR REF(CROSS(AO,0),1))))),COLORyellow;


DRAWICON(JDU1 OR BARSLAST(JDU1)<BARSLAST(JUD1),C,10),ALIGN4;

DRAWICON(JUD1 OR BARSLAST(JDU1)>BARSLAST(JUD1),C,11),ALIGN5;

回复 支持 反对

使用道具 举报

89#
发表于 2004-10-5 12:55:28 | 只看该作者
看不懂这些,有什么用呀?
回复 支持 反对

使用道具 举报

90#
发表于 2004-10-5 13:19:19 | 只看该作者
楼主辛苦,谢谢了!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

Copyright   ©2015-2016  蓝筹投资家园  Powered by©Discuz! 360网站安全检测平台   ( 沪ICP备19015253号 )
快速回复 返回顶部 返回列表